Legacy 5400N / 3400 Firmware


While we recommend that Rimage autoloaders utilize the latest firmware to ensure the best operation, we understand that sometimes an older version is useful. Find previous versions of the 5400N and 3400 firmware here.

Please make note if your system currently has 5.xxx or 6.xxx firmware installed and download the correct version for your system.

  • Systems with version 6.xxx cannot be programmed with version 5.xxx.
  • Systems with version 5.xxx cannot be programmed with version 6.xxx
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request